// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?msi)(select\s.*from\s|delete\s+from\s|insert\s+into\s.*values\s|update\s.*set\s)").unwrap();
let string = "Request osmcha analysis for changeset ids and update edits table with flags.
All cs ids are passed as a parameter to the api request (in case of a large
number of changesets,they will be split into multiple lists, i.e. this will
result in multiple requests).
The flags of each changeset are aggregated and uploaded into the db.
To see possible values of reasons look at osmcha_reasons.md.
:param settings:
:return:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}