$re = '/(select\s.*from\s|delete\s+from\s|insert\s+into\s.*values\s|update\s.*set\s)/msi';
$str = 'Request osmcha analysis for changeset ids and update edits table with flags.
All cs ids are passed as a parameter to the api request (in case of a large
number of changesets,they will be split into multiple lists, i.e. this will
result in multiple requests).
The flags of each changeset are aggregated and uploaded into the db.
To see possible values of reasons look at osmcha_reasons.md.
:param settings:
:return:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);