using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"taken\s(?<time_taken>\d+)\s";
string input = @"2020-04-09 23:33:51.120 INFO 1 --- [an-885-exec-8] c.z.q.p.serv.backendCall : time taken 11793 in ms";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}