package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)taken\s(?<time_taken>\d+)\s`)
var str = `2020-04-09 23:33:51.120 INFO 1 --- [an-885-exec-8] c.z.q.p.serv.backendCall : time taken 11793 in ms`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}