$re = '/taken\s(?<time_taken>\d+)\s/m';
$str = '2020-04-09 23:33:51.120 INFO 1 --- [an-885-exec-8] c.z.q.p.serv.backendCall : time taken 11793 in ms';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);