#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{5,80}$)\p{L}*(?: \p{L}+)+$"
Local $sString = ":OK" & @CRLF & _
"John D" & @CRLF & _
"john Doe" & @CRLF & _
"John X Doe" & @CRLF & _
"" & @CRLF & _
":Cannot have multiple spaces at once " & @CRLF & _
"John X Doe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")