re = /^(?=.{5,80}$)\p{L}*(?: \p{L}+)+$/m
str = ':OK
John D
john Doe
John X Doe
:Cannot have multiple spaces at once
John X Doe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end