$re = '/^(?=.{5,80}$)\p{L}*(?: \p{L}+)+$/m';
$str = ':OK
John D
john Doe
John X Doe
:Cannot have multiple spaces at once
John X Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);