#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=key)\s(?:\d+[\s,]+)+(?:and )?\d+"
Local $sString = "some text key 12, 32, 311 ,465 and 345. some other text dog 612, " & @CRLF & _
"12, 32, 9 and 10. some text key 1, 2." & @CRLF & _
"" & @CRLF & _
"a key is dog 3242342342, 345345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")