import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=key)\\s(?:\\d+[\\s,]+)+(?:and )?\\d+";
final String string = "some text key 12, 32, 311 ,465 and 345. some other text dog 612, \n"
+ "12, 32, 9 and 10. some text key 1, 2.\n\n"
+ "a key is dog 3242342342, 345345";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}