package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)([[:space:]])(.+)$`)
var str = `1529 33ER TAXI AG
2384 4EYES GMBH`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}