import re
regex = re.compile(r"^(\d+)([[:space:]])(.+)$", flags=re.MULTILINE)
test_str = ("1529 33ER TAXI AG \n"
"2384 4EYES GMBH")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")