#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=a href=")[^http](.*?)(\.html")"
Local $sString = "<a href="http://www.example.com/foo/bar.html">bar</a><a href="/foo/bar.html"><a href="/foo/bar.html">foo</a>" & @CRLF & _
"" & @CRLF & _
"<a href="bar/foo.html">foo</a><a href="../../bar/foo.html">foo</a><a href="http://www.example.com/bar/foo.html">foo</a>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")