$re = '/(?<=a href=")[^http](.*?)(\.html")/';
$str = '<a href="http://www.example.com/foo/bar.html">bar</a><a href="/foo/bar.html"><a href="/foo/bar.html">foo</a>
<a href="bar/foo.html">foo</a><a href="../../bar/foo.html">foo</a><a href="http://www.example.com/bar/foo.html">foo</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);