import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=a href=\")[^http](.*?)(\\.html\")";
final String string = "<a href=\"http://www.example.com/foo/bar.html\">bar</a><a href=\"/foo/bar.html\"><a href=\"/foo/bar.html\">foo</a>\n\n"
+ "<a href=\"bar/foo.html\">foo</a><a href=\"../../bar/foo.html\">foo</a><a href=\"http://www.example.com/bar/foo.html\">foo</a>\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}