package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\s\d]{1,13}$`)
var str = `123451 444444`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}