const regex = /^[\s\d]{1,13}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\s\\d]{1,13}$', '')
const str = `123451 444444`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}