#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?\d+(?:_\d+)*(?:\.\d+(?:_\d+)*)?$"
Local $sString = "1_2.3_4" & @CRLF & _
"1" & @CRLF & _
"-1" & @CRLF & _
"1.2" & @CRLF & _
"-1.2" & @CRLF & _
"0" & @CRLF & _
"0.00" & @CRLF & _
"0.1" & @CRLF & _
"000_00.00" & @CRLF & _
"0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")