const regex = /(\d{1,2}\s\w+\s(?:\d{4}|\d{2}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2}\\s\\w+\\s(?:\\d{4}|\\d{2}))', 'gm')
const str = `26 March 21 , 19 Feb 2021,12 Feb 21,19 March 21\\
2 Mar 21 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}