$re = '/(\d{1,2}\s\w+\s(?:\d{4}|\d{2}))/m';
$str = '26 March 21 , 19 Feb 2021,12 Feb 21,19 March 21\\
2 Mar 21 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);