import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\<th[^\\>]*?\\>|\\<td[^\\>]*?\\>)(?:\\r?\\n)?([\\s\\S]*?)(?:\\r?\\n)?(\\<\\/\\\\1\\>)";
final String string = "<table>\n"
+ "<tr>\n"
+ " <th> test th </th>\n"
+ "</tr><tr>\n"
+ " <td> test td </td>\n"
+ "</tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}