const regex = /\(\<th[^\>]*?\>|\<td[^\>]*?\>)(?:\r?\n)?([\s\S]*?)(?:\r?\n)?(\<\/\\1\>)/gmiu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\<th[^\\>]*?\\>|\\<td[^\\>]*?\\>)(?:\\r?\\n)?([\\s\\S]*?)(?:\\r?\\n)?(\\<\\\/\\\\1\\>)', 'gmiu')
const str = `<table>
<tr>
<th> test th </th>
</tr><tr>
<td> test td </td>
</tr>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}