#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)<(th|td)[^>]*>\r?\n?([\s\S]*?)\r?\n?<\/\1>"
Local $sString = "<table>" & @CRLF & _
"<tr>" & @CRLF & _
" <th> test th </th>" & @CRLF & _
"</tr><tr>" & @CRLF & _
" <td> test td </td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")