re = /<(th|td)[^>]*>\r?\n?([\s\S]*?)\r?\n?<\/\1>/mi
str = '<table>
<tr>
<th> test th </th>
</tr><tr>
<td> test td </td>
</tr>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end