$re = '/<(th|td)[^>]*>\r?\n?([\s\S]*?)\r?\n?<\/\1>/miu';
$str = '<table>
<tr>
<th> test th </th>
</tr><tr>
<td> test td </td>
</tr>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);