import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\<OBJ_CODE\\>).*(?=\\<\\/OBJ_CODE\\>)";
final String string = " <OBJ_CODE>(01)08699543091808(21)1000153104910(91)9185(92)92JEIF840$JDFDSA!L;ASDJASDMASDLKFJANE;ASDFLHJA(17)251231</OBJ_CODE>\n"
+ " </item>\n"
+ " <item>\n"
+ " <OBJ_CODE>(01)08699543091808(21)1000181393500(91)9185(92)92546KLJDF(G9)AALDFJ^KLJBN346#NDSFL%LKJADADNRI(17)251231</OBJ_CODE>\n"
+ " </item>\n"
+ " <item>\n"
+ " <OBJ_CODE>(01)08699543091808(21)1000121219920(91)9185(92)92489345MDFSLK8945893,5HJDSFKL3$LKJSDGFALKJDFG(17)251231</OBJ_CODE>\n"
+ " </item>\n"
+ " <item>\n"
+ " <OBJ_CODE>(01)08699543091808(21)1000164832760(91)9185(92)92DSAFL48904!KASDFG^;LKJASDF%ASDFLKJNASL34JD34(17)251231</OBJ_CODE>\n"
+ " </item>\n"
+ " <item>\n"
+ " <OBJ_CODE>(01)08699543091808(21)1000124140420(91)9185(92)92%LSDAFASDF9084A;LKLJ!;LK(23)4ASDF724LK$LJ$;L(17)251231</OBJ_CODE>\n"
+ " </item>\n"
+ " <item>\n"
+ " <OBJ_CODE>(01)08699543091808(21)1000161028910(91)9185(92)92834HASKLJHSDA$KJH%;LHJL(DF)^ASDFKLJDSFLKW!;L(17)251231</OBJ_CODE>\n"
+ " </item>\n"
+ " <item>\n"
+ " <OBJ_CODE>(01)08699543091808(21)1000135787250(91)9185(92)9290KLKLNAB%KLJAKLJ^7DSFKLJASDG234KLJSD#4LHASD(17)251231</OBJ_CODE>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}