use strict;
my $str = ' <OBJ_CODE>(01)08699543091808(21)1000153104910(91)9185(92)92JEIF840$JDFDSA!L;ASDJASDMASDLKFJANE;ASDFLHJA(17)251231</OBJ_CODE>
</item>
<item>
<OBJ_CODE>(01)08699543091808(21)1000181393500(91)9185(92)92546KLJDF(G9)AALDFJ^KLJBN346#NDSFL%LKJADADNRI(17)251231</OBJ_CODE>
</item>
<item>
<OBJ_CODE>(01)08699543091808(21)1000121219920(91)9185(92)92489345MDFSLK8945893,5HJDSFKL3$LKJSDGFALKJDFG(17)251231</OBJ_CODE>
</item>
<item>
<OBJ_CODE>(01)08699543091808(21)1000164832760(91)9185(92)92DSAFL48904!KASDFG^;LKJASDF%ASDFLKJNASL34JD34(17)251231</OBJ_CODE>
</item>
<item>
<OBJ_CODE>(01)08699543091808(21)1000124140420(91)9185(92)92%LSDAFASDF9084A;LKLJ!;LK(23)4ASDF724LK$LJ$;L(17)251231</OBJ_CODE>
</item>
<item>
<OBJ_CODE>(01)08699543091808(21)1000161028910(91)9185(92)92834HASKLJHSDA$KJH%;LHJL(DF)^ASDFKLJDSFLKW!;L(17)251231</OBJ_CODE>
</item>
<item>
<OBJ_CODE>(01)08699543091808(21)1000135787250(91)9185(92)9290KLKLNAB%KLJAKLJ^7DSFKLJASDG234KLJSD#4LHASD(17)251231</OBJ_CODE>';
my $regex = qr/(?<=\<OBJ_CODE\>).*(?=\<\/OBJ_CODE\>)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}