package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\(\d+(?:\.\d+)?,\d+(?:\.\d+)?\))+$`)
var str = `(2.2,2.0321312)(1,12)(3.12,12.1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}