# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Action=)(\[[^,]+)//gm;t' <<< "2019-05-14 11:28:08,257 [tomcat-http--12] INFO com.my.org.SomeClass - Usage Event: ,SomeField=null,SomeOtherField=Some value,Action=[Name] Action Detail,OtherField=null"