const regex = /(Action=)(\[[^,]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Action=)(\\[[^,]+)', 'gm')
const str = `2019-05-14 11:28:08,257 [tomcat-http--12] INFO com.my.org.SomeClass - Usage Event: ,SomeField=null,SomeOtherField=Some value,Action=[Name] Action Detail,OtherField=null`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);