$re = '/(Action=)(\[[^,]+)/m';
$str = '2019-05-14 11:28:08,257 [tomcat-http--12] INFO com.my.org.SomeClass - Usage Event: ,SomeField=null,SomeOtherField=Some value,Action=[Name] Action Detail,OtherField=null';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;