import re
regex = re.compile(r"(\d+(?:\.\d+){0,1})", flags=re.MULTILINE)
test_str = ("file = 00:00:08\n"
"ss ssone 32.00\n"
"ssone sstwo 33.0\n"
"sstwo ssthree 35.0\n"
"11:12:13\n"
"ssfour ssfive 34.0\n"
"ssthree sssix 38.0\n"
"ssnine ssseven 39.0\n"
"13:12:11")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")