re = /(\d+(?:\.\d+){0,1})/m
str = 'file = 00:00:08
ss ssone 32.00
ssone sstwo 33.0
sstwo ssthree 35.0
11:12:13
ssfour ssfive 34.0
ssthree sssix 38.0
ssnine ssseven 39.0
13:12:11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end