// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+(?:\.\d+){0,1})").unwrap();
let string = "file = 00:00:08
ss ssone 32.00
ssone sstwo 33.0
sstwo ssthree 35.0
11:12:13
ssfour ssfive 34.0
ssthree sssix 38.0
ssnine ssseven 39.0
13:12:11";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}