re = /(?<name>\w+)\s*\(\K
(?<e>
[^()]+
|
[^()]*
\((?&e)\)
[^()]*
)*
(?=\))/mx
str = 'foo(() ((hello) world))
bar (hello world!)
baz((()))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end