import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^=]+\\s=\\s(?:(?!Hex-STRING:)[^:])*:?\\s*(?<value_v2c>(?:Hex-STRING: )?[^=]+?)(?: -|$)";
final String string = ".1.3.6.1.2.1.1.3.0 = Timeticks: (2624594000) 303 days, 18:32:20.00 - .1.3.6.1.6.3.1.1.4.1.0 = OID: .1.3.6.1.4.1.14179.2.6.3.39 - .1.3.6.1.4.1.14179.2.2.1.1.1.84.74.0.200.115.112 = Hex-STRING: 54 4A 00 C8 73 70 - .1.3.6.1.4.1.14179.2.2.2.1.1.84.74.0.200.115.112.0 = INTEGER: 0 - .1.3.6.1.4.1.14179.2.2.1.1.3.0 = STRING: \"NJTHAP027\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}