use strict;
my $str = '.1.3.6.1.2.1.1.3.0 = Timeticks: (2624594000) 303 days, 18:32:20.00 - .1.3.6.1.6.3.1.1.4.1.0 = OID: .1.3.6.1.4.1.14179.2.6.3.39 - .1.3.6.1.4.1.14179.2.2.1.1.1.84.74.0.200.115.112 = Hex-STRING: 54 4A 00 C8 73 70 - .1.3.6.1.4.1.14179.2.2.2.1.1.84.74.0.200.115.112.0 = INTEGER: 0 - .1.3.6.1.4.1.14179.2.2.1.1.3.0 = STRING: "NJTHAP027"';
my $regex = qr/[^=]+\s=\s(?:(?!Hex-STRING:)[^:])*:?\s*(?<value_v2c>(?:Hex-STRING: )?[^=]+?)(?: -|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}