package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:https?:\/\/(?:www)?\.?y(?:2u\.be|outu\.be|outube.com)\/)(?:watch\?v=)?([\w\d]+)`)
var str = `some https://www.youtube.com/watch?v=cYXI344Siew YT link`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}