const regex = /(?:https?:\/\/(?:www)?\.?y(?:2u\.be|outu\.be|outube.com)\/)(?:watch\?v=)?([\w\d]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/(?:www)?\\.?y(?:2u\\.be|outu\\.be|outube.com)\\\/)(?:watch\\?v=)?([\\w\\d]+)', 'gmi')
const str = `some https://www.youtube.com/watch?v=cYXI344Siew YT link`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}