re = /(?:https?:\/\/(?:www)?\.?y(?:2u\.be|outu\.be|outube.com)\/)(?:watch\?v=)?([\w\d]+)/mi
str = 'some https://www.youtube.com/watch?v=cYXI344Siew YT link'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end