use strict;
my $str = 'attr1=ActiveList attr2=<Resource URI\\="/All Active Lists/_CAL/Infrastructure/Active Directory/Inventory/Inventory - By User (Dedd)" ID\\="DSdddCcSSS\\=\\="/> attr3=ActiveLis attr4=ActiveList attr5=<Resource URI\\="/All Active Lists/_CAL/Infrastructure/Active Directory/Inventory/Inventory - By User (Bobo)" ID\\="CCCsSSdDDD\\=\\="/> attr6=ActiveLis';
my $regex = qr/\w+=(?:<([^>]*)>|(\S+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}