import Foundation
let pattern = #"\w+=(?:<([^>]*)>|(\S+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"attr1=ActiveList attr2=<Resource URI\="/All Active Lists/_CAL/Infrastructure/Active Directory/Inventory/Inventory - By User (Dedd)" ID\="DSdddCcSSS\=\="/> attr3=ActiveLis attr4=ActiveList attr5=<Resource URI\="/All Active Lists/_CAL/Infrastructure/Active Directory/Inventory/Inventory - By User (Bobo)" ID\="CCCsSSdDDD\=\="/> attr6=ActiveLis"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)