re = /\w+=(?:<([^>]*)>|(\S+))/
str = 'attr1=ActiveList attr2=<Resource URI\\="/All Active Lists/_CAL/Infrastructure/Active Directory/Inventory/Inventory - By User (Dedd)" ID\\="DSdddCcSSS\\=\\="/> attr3=ActiveLis attr4=ActiveList attr5=<Resource URI\\="/All Active Lists/_CAL/Infrastructure/Active Directory/Inventory/Inventory - By User (Bobo)" ID\\="CCCsSSdDDD\\=\\="/> attr6=ActiveLis'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end