using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*mailto:(.)[^.]*.\.([^@]*).*";
string substitution = @"\1 \2";
string input = @"[John.Doe@something.com](mailto:John.Doe@something.com)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}