// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*mailto:(.)[^.]*.\.([^@]*).*").unwrap();
let string = "[John.Doe@something.com](mailto:John.Doe@something.com)";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}