const regex = /.*mailto:(.)[^.]*.\.([^@]*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*mailto:(.)[^.]*.\\.([^@]*).*', 'gm')
const str = `[John.Doe@something.com](mailto:John.Doe@something.com)`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);