# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\s-]+/ /gm;t' <<< " Word - Another Wow --- ----- ------ ---- --- look-at-that "