import re
regex = re.compile(r"[\s-]+", flags=re.MULTILINE)
test_str = " Word - Another Wow --- ----- ------ ---- --- look-at-that "
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)