package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s+("[^"]*"|[^\s;]+)`)
var str = `cheese "stilton";pigeons 17; color "blue"; why "because I said so";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}