$re = '/(\w+)\s+("[^"]*"|[^\s;]+)/m';
$str = 'cheese "stilton";pigeons 17; color "blue"; why "because I said so";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);